Tag Archives: RIPV2

3.4.a Implement and troubleshoot RIPv2

timers and characteristics

from:

http://blog.ine.com/2010/04/15/how-basic-are-rip-timers-test-your-knowledge-now/

http://www.ciscopress.com/articles/article.asp?p=102174&seqNum=4

Update: how often to send updates in seconds
Invalid: how many seconds, since seeing a valid update, to consider the route invalid, and placing the route into hold down
Hold Down: Once in hold down, how long (in seconds) to “not believe” any equal or less impressive (worse) route updates for routes that are in hold down
Flush: how many seconds, since the last valid update, until we throw that route in the trash (garbage collection for un-loved non-updated routes)

default values

Update: 30
Invalid: 180
Hold Down: 180
Flush: 240

RIPv2 Summary

The characteristics of RIPv2 follow:

  • Distance-vector protocol.
  • Uses UDP port 520.
  • Classless protocol (support for CIDR).
  • Supports VLSMs.
  • Metric is router hop count.
  • Maximum hop count is 15; infinite (unreachable) routes have a metric of 16.
  • Periodic route updates sent every 30 seconds to multicast address 224.0.0.9.
  • 25 routes per RIP message (24 if you use authentication).
  • Supports authentication.
  • Implements split horizon with poison reverse.
  • Implements triggered updates.
  • Subnet mask included in route entry.
  • Administrative distance for RIPv2 is 120.
  • Used in small, flat networks or at the edge of larger networks.

 

 

3.4.b Describe RIPv6 [RIPng]

RIPv6 Routing Information Protocol (RIP) functions the same and offers the same benefits as IPv4 RIP v2. RIP enhancements for IPv6, detailed in RFC 2080, include support for IPv6 addresses and prefixes and the use of the all-RIP-devices multicast group address, FF02:: 9, as the destination address for RIP update messages.

RIPng sends updates on UDP port 521 using the multicast group FF02:: 9.

Adam, Paul (2014-07-12). All-in-One CCIE V5 Written Exam Guide (Kindle Locations 2963-2966).  . Kindle Edition.

http://www.tcpipguide.com/free/t_RIPngRIPv6MessageFormatandFeatures.htm

3.4.a Implement and troubleshoot RIPv2

The Cisco implementation of RIPv2 supports cleartext and Message Digest 5 (MD5) authentication, route summarization, classless inter-domain routing (CIDR), and variable-length subnet masks (VLSMs) over RIPv1.

Adam, Paul (2014-07-12). All-in-One CCIE V5 Written Exam Guide (Kindle Locations 2958-2960).  . Kindle Edition.

http://www.ciscopress.com/articles/article.asp?p=102174&seqNum=4

http://blog.ine.com/2010/04/15/how-basic-are-rip-timers-test-your-knowledge-now/ 

3.4.a Implement and troubleshoot RIPv2

ripv2

rip v2 is on r3 and r2, eigrp is on r1, r2 and r4…

router rip
version 2
network 0.0.0.0

redistribution occurs on r2…

R2#sh run | sec router rip
router rip
version 2
redistribute eigrp 1 metric 5
network 192.168.23.0

R2#sh run | sec eigrp
router eigrp 1
network 192.168.12.0
network 192.168.24.0
 redistribute rip metric 1 1 255 255 1500

R1#sh ip route eigrp | b Gate
Gateway of last resort is not set

D EX  3.0.0.0/8 [170/2560002816] via 192.168.12.2, 00:11:23, FastEthernet0/0
4.0.0.0/24 is subnetted, 1 subnets
D        4.4.4.0 [90/158720] via 192.168.12.2, 00:12:35, FastEthernet0/0
D EX  192.168.23.0/24
           [170/2560002816] via 192.168.12.2, 00:11:23, FastEthernet0/0
D     192.168.24.0/24 [90/30720] via 192.168.12.2, 00:14:52, FastEthernet0/0

rip authentication like eigrp uses key chains…

R3#sh run | sec key
key chain RIP
key 1
key-string cisco

R2(config-if)#do sh run int f1/0
Building configuration…

Current configuration : 166 bytes
!
interface FastEthernet1/0
ip address 192.168.23.2 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain RIP

R3#debug ip rip
RIP protocol debugging is on
R3#
*Apr 17 14:37:23.399: RIP: sending v2 update to 224.0.0.9 via FastEthernet1/0 (192.168.23.3)
*Apr 17 14:37:23.399: RIP: build update entries
*Apr 17 14:37:23.403:   3.0.0.0/8 via 0.0.0.0, metric 1, tag 0
R3#
*Apr 17 14:37:25.399: RIP: sending v2 update to 224.0.0.9 via Loopback0 (3.3.3.3)
*Apr 17 14:37:25.399: RIP: build update entries
*Apr 17 14:37:25.403:   1.0.0.0/8 via 0.0.0.0, metric 6, tag 0
*Apr 17 14:37:25.403:   4.0.0.0/8 via 0.0.0.0, metric 6, tag 0
*Apr 17 14:37:25.407:   192.168.12.0/24 via 0.0.0.0, metric 6, tag 0
*Apr 17 14:37:25.411:   192.168.23.0/24 via 0.0.0.0, metric 1, tag 0
*Apr 17 14:37:25.411:   192.168.24.0/24 via 0.0.0.0, metric 6, tag 0
*Apr 17 14:37:25.423: RIP: ignored v2 packet from 3.3.3.3 (sourced from one of our addresses)
R3#
*Apr 17 14:37:36.311: RIP: received packet with MD5 authentication
*Apr 17 14:37:36.311: RIP: received v2 update from 192.168.23.2 on FastEthernet1/0
*Apr 17 14:37:36.315:      1.0.0.0/8 via 0.0.0.0 in 5 hops
*Apr 17 14:37:36.315:      4.0.0.0/8 via 0.0.0.0 in 5 hops
*Apr 17 14:37:36.319:      192.168.12.0/24 via 0.0.0.0 in 5 hops
*Apr 17 14:37:36.319:      192.168.24.0/24 via 0.0.0.0 in 5 hops
R3#un all
All possible debugging has been turned off

 

3.4 RIP [v2 and v6]

3.4.a Implement and troubleshoot RIPv2

we mostly ignore it, but i just read through doyle’s rip chapter (again) so i thought i might build it… can’t hurt…

doyle_rip_tcpip

the first task is to build it… note the little blue rip below… that is the gns3 config zipped as in the diagram with only ip addressing… go ahead and download it… tell me if it opens fine… you’ll find the router files, and .net… the image is for  7200’s… with this latest version of gns3, just extract the files and launch gns3… it should prompt you to point to an ios image that you have available… if not, just manually change the image file location in the .net file… i just tested it and it works… this is something i’ve been meaning to do for a while… then, because i know you have the same books as i do because we share the same kind of insanity, go to page 195 of doyle’s routing tcpip and do the exercises for rip…

download the topology here:

down arrow smaller

ripzip

feel free to tell me how awesome i am at any time…

note: the working directory is not included in the zip for obvious reasons…