Tag Archives: 4.1b

4.1.b Implement and troubleshoot basic MPLS L3VPN

note: to find all the labs, select “lab” from categories, or click the “lab” tag in the tag cloud..

MPLS VPN Static Lab

mpls_vpn_static

down arrow smaller

 mpls_static_ospf

here is the dramatic finish:

mpls_static_ospf_trace

ospf and ldp verification

mpls_static_sh_ospf_ldp_neigh

this takes care of the vrf:

PE1#sh run | b vrf
ip vrf CE1
rd 100:1
route-target export 100:1
route-target import 100:1

interface FastEthernet0/0
ip vrf forwarding CE1
ip address 192.168.1.2 255.255.255.0

ip route vrf CE1 1.1.1.0 255.255.255.0 192.168.1.1

remember the CE’s have no knowledge of vrf; plain old ip route to the PE…

CE1#sh run | i ip route
ip route 0.0.0.0 0.0.0.0 192.168.1.2
CE1#

verify the vrf:

PE1#ping vrf CE1 ip 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/22/52 ms
PE1#

mpls_static_ospf_vpnv4

the bgp config:

PE1#sh run | sec bgp
router bgp 100
bgp log-neighbor-changes
neighbor 22.22.22.22 remote-as 100
neighbor 22.22.22.22 update-source Loopback0
!
 address-family vpnv4
neighbor 22.22.22.22 activate
neighbor 22.22.22.22 send-community both
exit-address-family
!
address-family ipv4 vrf CE1
network 192.168.1.0
redistribute static
exit-address-family

do the same for CE2, substituting the vrf, and the address-families with its valid parameters.

4.1.b Implement and troubleshoot basic MPLS L3VPN

4.1.b [i] L3VPN, CE, PE, P

Multiprotocol Label Switching (MPLS) was originally derived from Tag Switching, and various other vendor methods of IP-switching support enhancements in the scalability and performance of IP-routed networks by combining the intelligence of routing with the high performance of switching.

MPLS is now used for VPNs, which is an appropriate combination because MPLS decouples information used for forwarding of the IP packet (the label) from the information carried in the IP header.

MPLS VPNs can combine any of the following:

● Globally unique and routable addresses

● Globally unique, non-routable addresses

● Private addresses (RFC1918)

● Addresses that are neither globally unique nor private.

Label Switched Paths are bound to VPN-IP routes and are confined to the VPN Service Provider.

P Router or Provider Router is a Label Switch Router (LSR) that functions as a transit router of the core network. A Provider Edge router (PE router) is a router between one network service provider’s area and areas administered by other network providers.

The customer edge (CE) is the router at the customer premises that is connected to the provider edge of a service provider IP/ MPLS network. CE peers with the Provider Edge (PE) and exchanges routes with the corresponding VRF inside the PE. The routing protocol used could be static or dynamic (an Interior Gateway Protocol like OSPF or an Exterior Gateway Protocol like BGP).

Adam, Paul (2014-07-12). All-in-One CCIE V5 Written Exam Guide (Kindle Locations 4427-4430).  . Kindle Edition.

http://labelswitched.blogspot.com/2013/01/cisco-bgpmpls-l3vpn-basics.html