Tag Archives: 3.3i

3.3.i Implement, optimize and troubleshoot manual and auto summarization with any routing protocol

Routing protocols summarize or aggregate routes based on shared network numbers within the network. Classless routing protocols (such as RIPv2, OSPF, IS-IS, and EIGRP) support route summarization based on subnet addresses, including VLSM addressing. Classful routing protocols (RIPv1 and IGRP) automatically summarize routes on the classful network boundary and do not support summarization on any other bit boundaries. Classless routing protocols (RIPv2, OSPF, ISIS, EIGRP) support summarization on any bit boundary.

Route summarization reduces memory use on routers and routing protocol network traffic, because it results in fewer entries in the routing table (on the routers that receive the summarized routes). For summarization to work correctly, the following requirements must be met:

● Multiple IP addresses must share the same highest-order bits.

● Routing protocols must base their routing decisions on a 32-bit IP address and a prefix length that can be up to 32 bits.

● Routing updates must carry the prefix length (the subnet mask) along with the 32-bit IP address.

Adam, Paul (2014-07-12). All-in-One CCIE V5 Written Exam Guide (Kindle Locations 2780-2781).  . Kindle Edition.

http://www.ciscopress.com/articles/article.asp?p=174107&seqNum=3

 

3.3.i Implement, optimize and troubleshoot manual and auto summarization with any routing protocol

R3(config-if)#do sh run | sec Loopback1
interface Loopback10
ip address 172.16.1.1 255.255.255.0
interface Loopback11
ip address 172.16.0.1 255.255.255.0
interface Loopback12
ip address 172.16.2.1 255.255.255.0
interface Loopback13
ip address 172.16.3.1 255.255.255.0

R3(config-if)#do sh run int f0/0
Building configuration…

Current configuration : 152 bytes
!
interface FastEthernet0/0
ip address 192.168.34.3 255.255.255.0
 ip summary-address eigrp 1 172.16.0.0 255.255.252.0 5

R1(config)#do sh ip route eigrp
2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/410603] via 192.168.12.2, 02:27:50, FastEthernet0/0
3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/156260] via 192.168.13.3, 01:53:34, FastEthernet1/0
4.0.0.0/24 is subnetted, 1 subnets
D       4.4.4.0 [90/413163] via 192.168.13.3, 02:12:25, FastEthernet1/0
[90/413163] via 192.168.12.2, 02:12:25, FastEthernet0/0
D    192.168.24.0/24 [90/285163] via 192.168.12.2, 02:12:25, FastEthernet0/0
172.16.0.0/22 is subnetted, 1 subnets
D       172.16.0.0 [90/156260] via 192.168.13.3, 01:53:34, FastEthernet1/0
D    192.168.34.0/24 [90/285163] via 192.168.13.3, 02:27:36, FastEthernet1/0

 

3.3.i Implement, optimize and troubleshoot manual and auto summarization with any routing protocol

R8(config-router)#do sh ip int brie | b Loop
Loopback0                  8.8.8.8         YES manual up                    up
Loopback1                  172.16.0.1      YES manual up                    up
Loopback2                  172.16.1.1      YES manual up                    up
Loopback3                  172.16.2.1      YES manual up                    up

use area range on the abr for inter-area…

R7(config)#router ospf 1
R7(config-router)#area 1 range 172.16.0.0 255.255.252.0

R6(config-router)#do sh ip route ospf
172.16.0.0/22 is subnetted, 1 subnets
O IA    172.16.0.0 [110/3] via 10.1.67.7, 00:09:40, FastEthernet1/0

3.4.a Implement and troubleshoot RIPv2

R8(config-router)#do sh run | sec rip
router rip
version 2
network 0.0.0.0
no auto-summary

R7#sh ip route rip
172.16.0.0/24 is subnetted, 3 subnets
R       172.16.0.0 [120/1] via 10.1.78.8, 00:00:18, FastEthernet0/0
R       172.16.1.0 [120/1] via 10.1.78.8, 00:00:18, FastEthernet0/0
R       172.16.2.0 [120/1] via 10.1.78.8, 00:00:18, FastEthernet0/0
8.0.0.0/24 is subnetted, 1 subnets
R       8.8.8.0 [120/1] via 10.1.78.8, 00:00:18, FastEthernet0/0

R7#sh run | sec ospf
ip ospf authentication-key cisco
router ospf 1
log-adjacency-changes
summary-address 172.16.0.0 255.255.252.0
 redistribute rip subnets
network 0.0.0.0 255.255.255.255 area 0
redistribute ospf 1 metric 5

R5#sh ip route | i 172
172.16.0.0/22 is subnetted, 1 subnets
D EX    172.16.0.0

3.3.i Implement optimize and troubleshoot manual and auto summarization with any routing protocol

a guy at work asked me yesterday about summarization… he’s planning to take the ccna in a couple of months… the first thing i asked him was, did he understand subnetting and classful boundaries… the next thing i asked him was, did he understand powers of 2… i determined he was on the money so i told him the way i figure it out…

first, you must understand how to determine summarization with binary… why? because you must crawl before you run…

then, summarization can be determined with powers of 2 easily…

the initial supposition is that the aggregated route will be less than the classful boundary it rests on..

for example,if you have 172.16.1.1, 172.16.2.1 and 172.16.3.1/24 and you want to summarize, look at the third octet… the numbers 1 2 and 3 are the range…

the numbers 1 2 and three fall within the range of 4… 2 to the second = 4… in other words it takes 2 twos to get to four, or to encompass the range… subtract 2 from /24 and you have /22… or in binary count the bits up to where they change, as below…

10101100 00010000 00000001 00000001
10101100 00010000 00000010 00000001
10101100 00010000 00000011 00000001

if the range of numbers is 8: 2 to the third gets to 8… subtract 3 from /24 and you have /21…

it’s that easy if you’ve done the prior heavy lifting…