Tag Archives: 3.3a

3.3.a Implement and troubleshoot static routing

A router can learn about remote networks in one of two ways:

● Remote networks are manually entered into the route table using static routes.

● Remote routes are dynamically learned using a dynamic routing protocol.

Static routing provides some advantages over dynamic routing, including:

● Static routes are not advertised over the network, resulting in better security.

● Static routes use less bandwidth than dynamic routing protocols, as routers do not exchange routes.

● No CPU cycles are used to calculate and communicate routes.

● The path a static route uses to send data is known.

Static routing has the following disadvantages:

● Initial configuration and maintenance is time-consuming.

● Configuration can be error -prone, especially in large networks.

● Administrator intervention is required to maintain changing route information.

● Does not scale well with growing networks; maintenance becomes cumbersome.

● Requires complete knowledge of the whole network for proper implementation.

Adam, Paul (2014-07-12). All-in-One CCIE V5 Written Exam Guide (Kindle Locations 2637-2643).  . Kindle Edition.

http://www.ciscopress.com/articles/article.asp?p=2180209&seqNum=4

3.3 Fundamental routing concepts

3.3.a Implement and troubleshoot static routing

ipv6 static routing…

! The next command uses R1’s S0/0/1 as the outgoing interface
ipv6 route 2001:db8:1111:3::/64 S0/0/1

! The next command uses R2’s address as the next-hop router unicast address
ipv6 route 2001:db8:1111:3::/64 2001:DB8:1111:2::2

! The next command uses R1’s S0/0/1 as the outgoing interface, and
! R2’s link-local address as the next-hop router address
ipv6 route 2001:db8:1111:3::/64 S0/0/1 FE80::FF:FE00:2

 

3.3.f Implement and troubleshoot VRF lite

edit: not really vrf lite but this is as good a spot as any…

this was a great experiment i did last year to prove the veracity of vrf… it’s one of my most popular documents over on cln… it bears repeating…

https://learningnetwork.cisco.com/people/brian-osgood?view=documents

Sunday, May 27, 2012

vrf… the road to mpls…

this is the beginning of what would later bury frame relay…
notice the diagram… the ip addresses are the same for the clients… virtual route forwarding… see below
r1#ping 10.1.1.1Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r1#
r2#ping 10.1.1.1Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
r2#
r4#ping 10.1.1.1Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
r4#
each client router (ce, client edge) is connected to  r3 (pe, provider edge) with a virtual connection provided by vrf… like frame relay without the hassle of a frame switch… this would later give way to mpls, or frame tagging for the wan…
normally, if you try to assign the same addresses to interfaces the router complains you have overlapping ip’s… with a little variable magic, and very little at that, you can change the game…
r3#ping vrf r1 10.1.1.1Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r3#ping vrf r2 10.1.1.1Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
r3#ping vrf r4 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
r3#

first note the rd’s (route-distinguishers) in the diagram in global config…
then assign them to the interfaces…
interface FastEthernet0/0
ip vrf forwarding r1
ip address 10.1.1.1 255.255.255.0
speed 100
full-duplex
!
interface Serial0/0
ip vrf forwarding r2
ip address 10.1.1.1 255.255.255.0
encapsulation ppp
no fair-queue
clock rate 1000000
!
interface Serial0/1
ip vrf forwarding r4
ip address 10.1.1.1 255.255.255.0
encapsulation ppp
clock rate 1000000
of course, it’s just the beginning… you are running a separate route table for each vrf… see below
look ma, no global route table…
r3#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static routeGateway of last resort is not setr3#

then…

 

r3#sh ip route vrf r4Routing Table: r4
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static routeGateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.1.1.2/32 is directly connected, Serial0/1
C       10.1.1.0/24 is directly connected, Serial0/1
r3#

so what’s the big deal with mpls… it doesn’t have to dig into the packet, it labels the packet, it tags it, and uses cef to switch the hell out of it…

 

3.3 Fundamental routing concepts

  • 3.3.a Implement and troubleshoot static routing
  • 3.3.b Implement and troubleshoot default routing

sam, you made the pants too long…

i’ve worked with people in the past who refer to themselves as network engineers because they’ve been supporting networks for a long time… often, of course, they have no certification whatsoever… yet they are network engineers because, well, because they say so, that’s why… you know who you are… my feeling is the term network engineer has been so watered down by this practice of declaring oneself as such as to be completely meaningless…  fundamental concepts like the difference between a static route and a default route can distinguish the sheep from the shepherds…

hit it sam:

• Static routing refers to routes to destinations being listed manually, or statically, as the
   name implies, in the router. Network reachability in this case is not dependent on the
  existence and state of the network itself. Whether a destination is active or not, the
 static routes remain in the routing table, and traffic is still sent toward the specified
    destination.
• Default routing refers to a “last resort” outlet. Traffic to destinations that is unknown
         to the router is sent to that default outlet. Default routing is the easiest form of routing  for a domain connected to a single exit point.
• Dynamic routing refers to routes being learned via an interior or exterior routing
   protocol. Network reachability is dependent on the existence and state of the network.
  If a destination is down, the route disappears from the routing table, and traffic is not
   sent toward that destination.