4.1.a Implement and troubleshoot MPLS operations

odom_mplsvpn

will you ever in your career get a chance to do this… probably not… better enjoy it in your lab… thank God for gns3… it is the best thing since sliced toast…

pe1(config)#ip vrf cust-a
pe1(config-vrf)#rd 1:111
pe1(config-vrf)#route-target both 1:100
pe1(config-vrf)#do sh run | b ip vrf
ip vrf cust-a
rd 1:111
route-target export 1:100
 route-target import 1:100

pe1(config-vrf)#int f0/0
pe1(config-if)#ip vrf forward cust-a
% Interface FastEthernet0/0 IPv4 disabled and address(es) removed due to enabling VRF cust-a
pe1(config-if)#ip add 192.168.15.1 255.255.255.0
pe1(config-if)#do sh run int f0/0
Building configuration…

Current configuration : 123 bytes
!
interface FastEthernet0/0
ip vrf forwarding cust-a
ip address 192.168.15.1 255.255.255.0

pe1(config-if)#int f0/1
pe1(config-if)#ip vrf forward cust-b
% Interface FastEthernet0/1 IPv4 disabled and address(es) removed due to enabling VRF cust-b
pe1(config-if)#ip
*Apr 10 15:20:10.315: %LDP-5-INFO: default: LDP ID removed
pe1(config-if)#ip add 192.168.16.1 255.255.255.0
*Apr 10 15:20:24.359: %LDP-5-NBRCHG: LDP Neighbor 192.168.34.4:0 (1) is UP
pe1(config-if)#ip add 192.168.16.1 255.255.255.0
pe1(config-if)#
*Apr 10 15:20:26.775: %LDP-5-NBRCHG: LDP Neighbor 192.168.24.2:0 (2) is UP

do the mirror on the other side…

pe2#sh ip vrf
Name                             Default RD          Interfaces
cust-a                           1:111               Fa0/1
cust-b                           2:222               Fa1/0

add an igp to the customer routers…

ce-a1(config)#router eigrp 1
ce-a1(config-router)#netw 192.168.15.0
ce-a1(config-router)#netw 10.0.0.0

create the  igp process for the pe’s… the igp AS numbers don’t have to match, but the AS’s in the autonomous-system for the address-family of the vrf must…

pe1(config-if)#router eigrp 65001
pe1(config-router)#address-fam ipv4 vrf cust-a
pe1(config-router-af)#autonomous-system 1
pe1(config-router-af)#netw 192.168.15.1 0.0.0.0
pe1(config-router-af)#no
*Apr 11 05:32:34.983: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.15.5 (FastEthernet0/0) is up: new adjacency
pe1(config-router-af)#no auto
pe1(config-router-af)#address-fam ipv4 vrf cust-b
pe1(config-router-af)#autonom 1
pe1(config-router-af)#netw 192.168.16.1 0.0.0.0
pe1(config-router-af)#
*Apr 11 05:33:25.263: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.16.2 (FastEthernet0/1) is up: new adjacency

create the redistribution, both pe’s…

pe1(config)#router bgp 65001
pe1(config-router)#address-fam ipv4 vrf cust-a
pe1(config-router-af)#redist eigrp 1
pe1(config-router-af)#address-fam ipv4 vrf cust-b
pe1(config-router-af)#redist eigrp 1
pe1(config-router-af)#router eigrp 65001
pe1(config-router)#address-family ipv4 vrf cust-a
pe1(config-router-af)#redist bgp 65001 metric 1 0 1 255 1500
pe1(config-router-af)#address-fam ipv4 vrf cust-b
pe1(config-router-af)#redist bgp 65001 metric 1 0 1 255 1500
pe1(config-router-af)#end

verify…

pe1#sh ip bgp vpnv4 all | b Net
Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:111 (default for vrf cust-a)
*>  10.1.1.1/32      192.168.15.5        156160         32768 ?
*>  192.168.15.0     0.0.0.0                  0         32768 ?
Route Distinguisher: 2:222 (default for vrf cust-b)
*>  10.2.2.0/24      192.168.16.2        156160         32768 ?
*>  192.168.16.0     0.0.0.0                  0         32768 ?

launch the bgp neighborship…

router bgp 65001
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 65001
neighbor 3.3.3.3 update-source Loopback0
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family

pe2#sh ip bgp vpnv4 all | b Net
Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:111 (default for vrf cust-a)
*>i 10.1.1.1/32      1.1.1.1             156160    100      0 ?
*>  10.3.3.0/24      192.168.37.6        156160         32768 ?
*>i 192.168.15.0     1.1.1.1                  0    100      0 ?
*>  192.168.37.0     0.0.0.0                  0         32768 ?
Route Distinguisher: 2:222 (default for vrf cust-b)
*>  8.8.8.0/24       192.168.38.2        156160         32768 ?
*>i 10.2.2.0/24      1.1.1.1             156160    100      0 ?
*>i 192.168.16.0     1.1.1.1                  0    100      0 ?
*>  192.168.38.0     0.0.0.0                  0         32768 ?

that is a lot of work…

ce-b1#trace 8.8.8.8
Type escape sequence to abort.
Tracing the route to 8.8.8.8
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.16.1 36 msec 16 msec 20 msec
2 192.168.12.2 [MPLS: Labels 18/20 Exp 0] 64 msec 64 msec 72 msec
3 192.168.38.1 [MPLS: Label 20 Exp 0] 56 msec 48 msec 48 msec
4 192.168.38.2 64 msec *  88 msec
ce-b1#

ce-a1, of course, ain’t gettin it…

ce-a1#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
ce-a1#