Monthly Archives: August 2015

3.7.b Implement and troubleshoot IBGP and EBGP

bgp next-hop-self

the lab is beneath the arrow.

bgp_next-hop-self

down arrow smaller

bgp_next_hop_self

follow the instructions on the diagram carefully. below is the state you are achieving.

bgp_next-hop_sh_bgp

when i was just getting started with bgp next-hop-self gave me a friggin headache. next-hop-who, myself, hisself, next-hop-whoself?

note the asterisk for the 3 network. it’s valid but that dog don’t hunt. the next hop field is vital; from r2’s perspective, to get to r3’s 3 network it will have to bypass r1 completely and mysteriously find 100.1.1.3 to get to 3.3.3.3. it’s r1’s job to make it right. r1 IS THE next hop for r2 to get to r3.

R1(config-router)#neighbor 2.2.2.2 next-hop-self
R1(config-router)#!!! to get to 3.3.3.3, use me, abuse me!!!
R1(config-router)#

bgp_next-hop2r3

R2(config-router)#do ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/30/44 ms

i still don’t like next-hop-self…

4.1.b Implement and troubleshoot basic MPLS L3VPN

note: to find all the labs, select “lab” from categories, or click the “lab” tag in the tag cloud..

MPLS VPN Static Lab

mpls_vpn_static

down arrow smaller

 mpls_static_ospf

here is the dramatic finish:

mpls_static_ospf_trace

ospf and ldp verification

mpls_static_sh_ospf_ldp_neigh

this takes care of the vrf:

PE1#sh run | b vrf
ip vrf CE1
rd 100:1
route-target export 100:1
route-target import 100:1

interface FastEthernet0/0
ip vrf forwarding CE1
ip address 192.168.1.2 255.255.255.0

ip route vrf CE1 1.1.1.0 255.255.255.0 192.168.1.1

remember the CE’s have no knowledge of vrf; plain old ip route to the PE…

CE1#sh run | i ip route
ip route 0.0.0.0 0.0.0.0 192.168.1.2
CE1#

verify the vrf:

PE1#ping vrf CE1 ip 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/22/52 ms
PE1#

mpls_static_ospf_vpnv4

the bgp config:

PE1#sh run | sec bgp
router bgp 100
bgp log-neighbor-changes
neighbor 22.22.22.22 remote-as 100
neighbor 22.22.22.22 update-source Loopback0
!
 address-family vpnv4
neighbor 22.22.22.22 activate
neighbor 22.22.22.22 send-community both
exit-address-family
!
address-family ipv4 vrf CE1
network 192.168.1.0
redistribute static
exit-address-family

do the same for CE2, substituting the vrf, and the address-families with its valid parameters.

4.1.a Implement and troubleshoot MPLS operations

  • 4.1.a [i] Label stack, LSR, LSP
  • 4.1.a [ii] LDP
  • 4.1.a [iii] MPLS ping, MPLS traceroute

Stretch’s MPLS VPN Lab

http://packetlife.net/blog/2011/may/16/creating-mpls-vpn/

mpls_stretch

 down arrow smaller

 mpls_stretch_lab

i like this one, especially the use of ospf process id’s, and the redistribution of ospf into ospf.

Thanks Stretch…