Monthly Archives: March 2014

3.3.i Implement, optimize and troubleshoot manual and auto summarization with any routing protocol

R3(config-if)#do sh run | sec Loopback1
interface Loopback10
ip address 172.16.1.1 255.255.255.0
interface Loopback11
ip address 172.16.0.1 255.255.255.0
interface Loopback12
ip address 172.16.2.1 255.255.255.0
interface Loopback13
ip address 172.16.3.1 255.255.255.0

R3(config-if)#do sh run int f0/0
Building configuration…

Current configuration : 152 bytes
!
interface FastEthernet0/0
ip address 192.168.34.3 255.255.255.0
 ip summary-address eigrp 1 172.16.0.0 255.255.252.0 5

R1(config)#do sh ip route eigrp
2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/410603] via 192.168.12.2, 02:27:50, FastEthernet0/0
3.0.0.0/24 is subnetted, 1 subnets
D       3.3.3.0 [90/156260] via 192.168.13.3, 01:53:34, FastEthernet1/0
4.0.0.0/24 is subnetted, 1 subnets
D       4.4.4.0 [90/413163] via 192.168.13.3, 02:12:25, FastEthernet1/0
[90/413163] via 192.168.12.2, 02:12:25, FastEthernet0/0
D    192.168.24.0/24 [90/285163] via 192.168.12.2, 02:12:25, FastEthernet0/0
172.16.0.0/22 is subnetted, 1 subnets
D       172.16.0.0 [90/156260] via 192.168.13.3, 01:53:34, FastEthernet1/0
D    192.168.34.0/24 [90/285163] via 192.168.13.3, 02:27:36, FastEthernet1/0

 

3.3.i Implement, optimize and troubleshoot manual and auto summarization with any routing protocol

R8(config-router)#do sh ip int brie | b Loop
Loopback0                  8.8.8.8         YES manual up                    up
Loopback1                  172.16.0.1      YES manual up                    up
Loopback2                  172.16.1.1      YES manual up                    up
Loopback3                  172.16.2.1      YES manual up                    up

use area range on the abr for inter-area…

R7(config)#router ospf 1
R7(config-router)#area 1 range 172.16.0.0 255.255.252.0

R6(config-router)#do sh ip route ospf
172.16.0.0/22 is subnetted, 1 subnets
O IA    172.16.0.0 [110/3] via 10.1.67.7, 00:09:40, FastEthernet1/0

3.4.a Implement and troubleshoot RIPv2

R8(config-router)#do sh run | sec rip
router rip
version 2
network 0.0.0.0
no auto-summary

R7#sh ip route rip
172.16.0.0/24 is subnetted, 3 subnets
R       172.16.0.0 [120/1] via 10.1.78.8, 00:00:18, FastEthernet0/0
R       172.16.1.0 [120/1] via 10.1.78.8, 00:00:18, FastEthernet0/0
R       172.16.2.0 [120/1] via 10.1.78.8, 00:00:18, FastEthernet0/0
8.0.0.0/24 is subnetted, 1 subnets
R       8.8.8.0 [120/1] via 10.1.78.8, 00:00:18, FastEthernet0/0

R7#sh run | sec ospf
ip ospf authentication-key cisco
router ospf 1
log-adjacency-changes
summary-address 172.16.0.0 255.255.252.0
 redistribute rip subnets
network 0.0.0.0 255.255.255.255 area 0
redistribute ospf 1 metric 5

R5#sh ip route | i 172
172.16.0.0/22 is subnetted, 1 subnets
D EX    172.16.0.0

3.3.e Implement and troubleshoot passive interface

R1(config-router)#passive-interface default
R1(config-router)#
*Mar  2 22:59:30.016: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.13.3 (FastEthernet1/0) is down: interface passive
*Mar  2 22:59:30.032: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.15.5 (FastEthernet2/0) is down: interface passive

R1(config-router)#no passive-int f1/
% Incomplete command.

R1(config-router)#no passive-int f1/0
R1(config-router)#
*Mar  2 23:01:30.800: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.13.3 (FastEthernet1/0) is up: new adjacency
R1(config-router)#no passive-int f2/0
R1(config-router)#
*Mar  2 23:01:38.728: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.15.5 (FastEthernet2/0) is up: new adjacency

R6(config)#router ospf 1
R6(config-router)#pass defa
R6(config-router)#
*Mar  2 23:03:32.260: %OSPF-5-ADJCHG: Process 1, Nbr 7.7.7.7 on FastEthernet1/0 from FULL to DOWN, Neighbor Down: Interface down or detached
R6(config-router)#no passive-int f1/0
R6(config-router)#
*Mar  2 23:04:02.264: %OSPF-5-ADJCHG: Process 1, Nbr 7.7.7.7 on FastEthernet1/0 from LOADING to FULL, Loading Done

 

3.3.h Implement, optimize and troubleshoot redistribution between any routing protocol

also

  • 3.3.a Implement and troubleshoot static routing
  • 3.3.b Implement and troubleshoot default routing

eigrp INTO ospf (note default-information originate always)

R6#sh run | sec router ospf
router ospf 1
log-adjacency-changes
redistribute eigrp 1 subnets
network 6.6.6.0 0.0.0.255 area 0
network 10.1.67.0 0.0.0.255 area 0
 default-information originate always

ospf INTO eigrp

router eigrp 1
 redistribute ospf 1 metric 1 1 255 255 1500
network 6.6.6.0 0.0.0.255
network 192.168.36.0
no auto-summary

R7#sh ip route ospf
1.0.0.0/24 is subnetted, 1 subnets
O E2    1.1.1.0 [110/20] via 10.1.67.6, 00:21:34, FastEthernet1/0
O E2 192.168.13.0/24 [110/20] via 10.1.67.6, 00:21:34, FastEthernet1/0
3.0.0.0/24 is subnetted, 1 subnets
O E2    3.3.3.0 [110/20] via 10.1.67.6, 00:21:34, FastEthernet1/0
O E2 192.168.15.0/24 [110/20] via 10.1.67.6, 00:21:34, FastEthernet1/0
4.0.0.0/24 is subnetted, 1 subnets
O E2    4.4.4.0 [110/20] via 10.1.67.6, 00:21:34, FastEthernet1/0
5.0.0.0/24 is subnetted, 1 subnets
O E2    5.5.5.0 [110/20] via 10.1.67.6, 00:21:34, FastEthernet1/0
6.0.0.0/32 is subnetted, 1 subnets
O       6.6.6.6 [110/2] via 10.1.67.6, 00:21:34, FastEthernet1/0
O E2 192.168.36.0/24 [110/20] via 10.1.67.6, 00:21:34, FastEthernet1/0
O E2 192.168.34.0/24 [110/20] via 10.1.67.6, 00:21:34, FastEthernet1/0
O E2 192.168.35.0/24 [110/20] via 10.1.67.6, 00:21:34, FastEthernet1/0
O*E2 0.0.0.0/0 [110/1] via 10.1.67.6, 00:06:33, FastEthernet1/0

v5_practice

R7#trace 200.1.1.2

Type escape sequence to abort.
Tracing the route to 200.1.1.2

1 10.1.67.6 64 msec 68 msec 16 msec
2 192.168.36.3 84 msec 72 msec 24 msec
3 192.168.34.4 48 msec 88 msec 72 msec
4 200.1.1.2 144 msec *  128 msec

R2#sh run | sec ip route
ip route 192.168.13.0 255.255.255.0 100.1.1.1
ip route 192.168.34.0 255.255.255.0 200.1.1.1

R1#sh run | sec ip route
ip route 0.0.0.0 0.0.0.0 100.1.1.2

R4#sh run | sec ip route
ip route 0.0.0.0 0.0.0.0 200.1.1.2

R1#sh ip route | i Gate
Gateway of last resort is 100.1.1.2 to network 0.0.0.0

3.3.n Implement and troubleshoot routing protocol authentication

3.3.n Implement and troubleshoot routing protocol authentication

  • 3.3.n [i] MD5

md5 is the only authentication mode for EIGRP

R3(config-keychain-key)#do sh run | sec key
key chain CHAIN
key 1
key-string cisco

R3#sh run int f3/0 | i ip
ip address 192.168.36.3 255.255.255.0
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 CHAIN

R3#debug eigrp pack hello
EIGRP Packets debugging is on
(HELLO)
R3#
*Mar  1 02:54:10.159: EIGRP: received packet with MD5 authentication, key id = 1

R6(config)#key chain CHAIN
R6(config-keychain)#key 1
R6(config-keychain-key)#key-string psycho
R6(config-keychain-key)#
*Mar  1 02:57:30.887: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.36.3 (FastEthernet0/0) is down: Auth failure

for ospf null (0) is the default

R7#debug ip ospf pack
OSPF packet debugging is on
R7#
*Mar  1 00:07:19.935: OSPF: rcv. v:2 t:1 l:48 rid:6.6.6.6
aid:0.0.0.0 chk:3871 aut:0 auk: from FastEthernet1/0

for plain text authentication (1). in router configuration mode the area configuration is optional:

R6#sh run int f1/0 | i auth
ip ospf authentication
ip ospf authentication-key cisco

R6(config-if)#
*Mar  1 03:25:38.799: OSPF: rcv. v:2 t:1 l:48 rid:7.7.7.7
aid:0.0.0.0 chk:3870 aut:1 auk: from FastEthernet1/0

md5 authentication is (2)

R6#sh run int f1/0 | i auth
ip ospf authentication message-digest
ip ospf authentication-key cisco

R6#
*Mar  1 03:30:08.759: OSPF: rcv. v:2 t:1 l:48 rid:7.7.7.7
aid:0.0.0.0 chk:0 aut:2 keyid:0 seq:0x3C7ECB35 from FastEthernet1/0

BGP wins; only md5 and the easiest of all..

R7(config-router)#do sh run | sec bgp
router bgp 1
neighbor 6.6.6.6 remote-as 1
neighbor 6.6.6.6 password cisco