Monthly Archives: June 2013

3.6.c Implement and troubleshoot OSPFv3 address-family support

3.6.c [i] IPv4 address-family

eigrp, like its big brother bgp plays well with address families…

PE2(config-router-af)#do sh run | b eigrp
router eigrp 2
network 192.168.78.0
no auto-summary
!
address-family ipv4 vrf arc
network 192.168.78.0
no auto-summary
autonomous-system 2
exit-address-family

ospf however, requires a different method to be placed in a vrf:

router ospf 3 vrf toy
log-adjacency-changes
network 192.168.79.0 0.0.0.255 area 0

why? because address families didn’t get support until ospfv3…

according to rfc 5838: http://tools.ietf.org/html/rfc5838

Support of Address Families in OSPFv3

Abstract

   This document describes a mechanism for supporting multiple address
   families (AFs) in OSPFv3 using multiple instances.  It maps an AF to
   an OSPFv3 instance using the Instance ID field in the OSPFv3 packet
   header.  This approach is fairly simple and minimizes extensions to
   OSPFv3 for supporting multiple AFs.

3.7.f Implement and troubleshoot multiproctocol BGP

3.7.f [i] IPv4, IPv6, VPN address-family

when you know you’re going to use multiprotocol bgp, as in mpls vpn, it is perhaps a good practice to define and place the specific address family commands in their proper cubicles as you configure…

for instance, note below the ipv4 config is not delimited, while the vpnv4 config necessarily is:

router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 7.7.7.7 remote-as 1
neighbor 7.7.7.7 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community extended
exit-address-family

ivan has an instructive article about this here… http://blog.ioshints.info/2008/06/use-explicit-address-family-ipv4-in-bgp.html

further, it might prove useful when simply using plain bgp to get in the habit of using the address family configuration…

there is also a way to automatically convert this after the fact:

PE1(config-router)#bgp upgrade-cli
You are about to upgrade to the AFI syntax of bgp commands

Are you sure ? [yes]: y
PE1(config-router)#do sh run | b bgp
router bgp 1
bgp log-neighbor-changes
neighbor 7.7.7.7 remote-as 1
neighbor 7.7.7.7 update-source Loopback0
!
address-family ipv4
neighbor 7.7.7.7 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community extended
exit-address-family

how about that?

3.6.d Implement and troubleshoot network types area types and router types

3.6.d [i] Point-to-point, multipoint, broadcast, non-broadcast

in the ccnp net acad lab manual for route (if you are heading towards ccnp, i highly recommend doing all three net acad lab manuals) the idea of a loopback in ospf taking on characteristics of a host in the routing table was stressed… that would manifest itself as a /32 in the routing table, where a /24 would be preferred… hence ip ospf network point-to-point placed on the loopback interface would make it a network… good…

not doing so in an ospf mpls network will bite you in the ass…

note, i turned off ip ospf network point-to-point on the loopback of the other pe router, but the routes still show up…

Branch#sh ip route | b Gate
Gateway of last resort is not set

D    192.168.12.0/24 [90/30720] via 192.168.45.4, 00:16:35, FastEthernet0/0
1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/158720] via 192.168.45.4, 00:16:35, FastEthernet0/0
C    192.168.45.0/24 is directly connected, FastEthernet0/0
5.0.0.0/24 is subnetted, 1 subnets
C       5.5.5.0 is directly connected, Loopback0
Branch#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)

then:

PE1(config-if)#ip ospf netw point-to-p
PE1(config-if)#

and:

Branch#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/77/80 ms

note that the routes show up in either case but they are not reachable without ip ospf network point-to-point..

more on this later